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PC Setup 

Getting Capture Pro Software License 
There are two ways to get a license: 

1. Get the license before installing the Capture Pro software. This method was used the initial time because 
it allowed us to get a license for a longer than the default 30 days. This is the easiest way for the person 
creating the license. 

2. Install Capture Pro software, which will give a license for 30 days. Use this option if you cannot wait for 
the longer license (e.g. stuck at competition and need to get a PC up and running). The license turned into 
a longer one, but it is a little more work for the person creating the license. 

 

Get License Before Installing 

Need to get the License Manager Tool (i.e. KCSPLM_4_1_5.exe). This can be found at on the web: 

1. goto: http://www.kodakalaris.com/go/capturepro 

2. if we get the “Welcome To Kodak Worldwide” page, pick United States 

3. click the “Download Trial Edition” button 

4. scroll to the bottom of the page to find “License Manager” 

5. click the Download button to the right of it 

6. run KCSPLM_4_1_5.exe 

7. use the detail actions for all the install prompts 

8. after install is complete, run License Manager 
(it is in: Start -> All Programs -> Kodak -> Kodak License Manager Tool) 

9. click the “Show Hardware ID” button (near the button left of the screen) 

10. make a copy of the code in the “Hardware ID:” edit box (this is what you send to the license person) 

11. click Close button 

12. send Hardware ID to the license person 

Update License After Installing 

NOTE: License person will need to update your license offline, so it could take time to get it updated 

1. run Capture Pro (Start -> KODAK -> KODAK  Capture Pro Software - > KODAK Capture Pro Software)  

2. in the Help menu, select License Manager 

3. click “Show Hardware ID” 

4. make a copy of the code in the “Hardware ID:” edit box and send to the license person 

5. wait until license person updates your license 

6. click “Get License” 

7. click OK 

8. click Close 

  

http://www.kodakalaris.com/go/capturepro


Scouting System Setup and Use 2/11/14 v1.1 Page 4 of 15 

Install Capture Pro 
.NET 4.0 and an Internet connection are required for install. The steps are: 

1. goto: http://www.kodakalaris.com/go/capturepro 

2. if we get the “Welcome To Kodak Worldwide” page, pick United States 

3. click the “Download Trial Edition” button 

4. scroll to the “Capture Pro Software” section 

5. click the Download button (file would be names something like CapProSW_4_5_0.exe) 

6. run installer 

7. when prompted select “I will not be using a USB Hardware Key” 

8. do NOT select “Install as Kodak Capture Pro Network  Edition Client” 

9. select “I have not purchased the product. I would like a Trial license” 

10. If you do not want to enter contact information, then for “Registration ID” enter: KC10302642 
NOTE: for 1511, use the above registration ID 

11. if you do not use the registration ID, then follow the prompts to enter your contact information 

12. when prompted for a Setup Type, select: Typical. 

13. follow the prompts to complete the install 

NOTE: each time you start Capture Pro you will be prompted with the number days and pages left before the 
license will expire; click OK. 
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Install SCANMATE i920/i940 Scanner Driver 

Have Small Install 

If you do access to the installer (e.g. i900_Windows_v2.19.zip), then do the following: 
1. extract the contents of the ZIP to a folder on the PC 

2. run the setup.exe that was extracted and select the defaults for all prompts 

3. continue with ‘Common Steps’ below 

Get Install from Web 

If you do not have access to the installer, then do the following: 
1. goto: http://www.kodakalaris.com/go/scanners 

2. under “Workgroup”, select i940 (if not listed, select “Support Center” on the right; then 
Scanners -> Workgroup -> SCANMATE i940 Scanner -> Downloads) 

3. click “Support” tab 

4. find the Windows drivers and click its “Details” 

5. scroll down and find the Windows Install Software and click “Download” button 

6. run the exe that was downloaded and select the defaults for all prompts 

7. continue with ‘Common Steps’ below 

Common Steps 

1. attach the USB cable to the scanner and the PC 

2. connect power to the scanner and outlet 

3. open the scanner lid (this turns on the scanner) 

4. In the lower-right corner of Windows (i.e. the System Tray), you should see a balloon pop-up saying that it 

is installing the scanner 

5. Once Windows as installed the driver, the balloon will say that the scanner is ready for use 

NOTE: it’s ok to connect to a different USB port later on, just realize you will get the two balloon popups again  

Create Base Folder 
Need a folder to store all the files and scanned data. On the root of the C: drive, create “scouting” (i.e. 

c:\scouting). 
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Create a Database Connector 
This is needed so the match data can be appended as the day progresses. Otherwise, you will end up with a 

different .csv file each time you scan some sheets. 

The best thing is to have a ‘blank’ .csv file that defines all the column headings. That is a file with one line of text, 
each column heading is surrounded by double-quotes, and a comma placed between each column. You will want 
one column each question/item you will get from the souting sheet. For example: 

"Team Num","Match Num","Auto Points","Question 1","Question 2","etc" 

1. copy the ‘blank’ .csv file into c:\scouting 

2. from the Start menu, type in and run the program: C:\Windows\SysWOW64\odbcad32.exe 

3. click the “System DSN” tab 

4. click Add… 

5. scroll down and select “Microsoft Text Driver (*.txt; *.csv)” 

6. click Finish 

7. for “Data Source Name” enter a name that matches the name of the .csv (e.g. aerialassist) 

8. for “Description” enter the same name you entered for “Data Source Name” 

9. uncheck “Use Current Directory” 

10. click “Selected Directory…” 

11. navigate to c:\scouting (you know this is done when you see the .csv file show up in the list on the left) 

12. with “scouting” highlighted, click OK 

13. click OK (you will then be back at the “System DSN” tab) 

14. select ‘Name’ you just added (e.g. aerialassist), then click “Configure…” 

15. click “Options >>” 

16. click “Define Format…” 

17. in the ‘Tables” list, select your .csv file (e.g. aerialassist.csv) 

18. check “Column Name Header” 

19. click “Guess” (this will fill in the ‘Columns’ list with all the column headings from the file) 

20. next to “Characters”, select “ANSI” 

21. click OK (you will then be on the “ODBC Text Setup” screen 

22. click OK (you will then be back at the “System DSN” tab) 

23. click OK (the ODBC tool will now be closed) 
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Setup Capture Pro 
NOTE: it is possible to skip this entire section if you a copy of the job setup folder that was previously completed. 

You would unzip the folder into c:\Users\Public\Documents\KCS Pros\Job Setup (e.g. you would have a Scouting 

folder in the Job Setup folder, and in the Scouting folder would be folders like: Barcode, …, OCR, …, Scample 

Images, etc. 

1. run Capture Pro (Start -> KODAK -> KODAK  Capture Pro Software - > KODAK Capture Pro Software) 

2. if prompted to setup scanner, click No 

3. on Batch Manager screen, click Close 

4. attach the scanner to the PC and power outlet; then open the scanner lid 

Configure Scanner Settings 

1. select File -> Workstation Setup 

2. in the Scanner group, click Setup… 

3. select “KODAK Scanner: i900” 

4. click OK (you will then be on the Workstation Setup screen) 

5. click OK (you will then be on the main Capture Pro screen) 

6. click File -> Page Setup 

7. to the right of the “Page setup name:”, click the blue floppy button (i.e. Save As) 

8. for “Page setup name:”, enter: scouting 

9. click Save 

10. click “Settings…” 

11. within “Setting Shortcuts”, select “Black and White Perfect Page Document”  

12. for “Input document is”, select “One Sided - Front” 

13. on the toolbar, click “Scan As…” 

14. for “Shortcut name:”, enter “scouting” 

15. click Save 

16. click OK (you will then be on the Page Setup screen) 

17. remove all other choices in “Page setup name:” 

a. select the “Page setup name:” 

b. click the Delete tool (trash can on the right) 

c. click Yes 

d. repeat the above steps all names, expect for “scouting” 

18. click OK (you should now be at the main Capture Pro screen 
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Configure Initial Job Settings 

1. select File -> Job Setup 

2. to the right of the “Job name:”, click the blue floppy button (i.e. Save As) 

3. for “Page setup name:”, enter: Scouting 

4. click Save 

5. At this point you should be on the “Capture” tab and ‘General’ selected 

6. for “Scanned image location:” enter: c:\scouting\input 

7. for “Output image location:” enter: c:\scouting\output 

8. check “Automatically output when batch is closed” 

9. in the list on the left, select ‘Separation’ 

10. in “Document Level” group, check “Every” 

11. select “Output” tab 

12. in the list on the left, select “File(1).TIFF” (be sure it remains checked) 

13. uncheck “All” 

14. check “Black & White” 

15. on the right “Black & White”, click Setup 

16. for the “Location formula”, enter: <EXPORT_PATH>"\"<BATCH_NAME>"\images" 

17. click “File name” tab, enter: <DOCUMENT_ID>"_"<IMAGE_SEQUENCENUMBER_8><DEFAULT_EXT> 

18. for “Duplicate file handling” select “Add a sequence number to the name” 

19. click OK 

20. under “File(1).TIFF” in the list on the left, select “Index:XML” (NOTE: might end with something else 

besides XML) 

21. uncheck “Batch index file:” 

22. make sure “Image index file:” it no checked 

23. check “Document index file:” 

24. in the dropdown for “Document index file:”, select “Index to ODBC Database” 

25. next to dropdown for “Document index file:”, click “Options…” 

26. click “Browse…” 

27. on the “Select Data Source” screen, click the “Machine Data Source” tab 

28. select the ‘Data Source Name’ from the list (e.g. aerialassist) 

29. click OK 

30. in the “Database table” table dropdown, select the .csv file (e.g. ‘C:\scouting’\’aerialassist.csv’) 

31. click OK (NOTE: we will come back later and update the list of fields) 

32. click “Content…” 

a. for “Field delimiter:”, enter “,” (without the double-quotes) 

b. for “Item Delimiter:”, select “”” 

c. click “Remove All” to remove all items from the “Current indexes:” list 

d. click OK (you will then back on the “Job Setup” screen) 

33. click OK (this will exit the Job Setup screen and save your changes so far) 
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Configure Detection Zones 

1. select File -> Job Setup 

2. for “Job Name:”, select “Scouting” 

3. in the Capture list on the left, select “Barcode, OCR & Mark Detection” 

4. make sure the scanner is connected and turned on 

5. get a sample form and place it in the scanner; front side goes against the scanner’s tray, and the top edge 

of the page goes into the scanner first (i.e. flip paper so you see the back of it, then rotate it 180 degrees 

so the top is now the bottom) 

6. you will want to make sure the paper is scanned straight, so make sure the side guides are against the 

paper 

7. on the Job Setup screen, click the “Start Scan” tool (green circle with white arrow) 

8. enter an “Image name:” (e.g. Aerial) 

9. press Scan button (green arrow) 

10. you want to make sure the image is good. you want to make sure the page is rectangular and there are no 

big black slivers around it; very very line slivers are ok. if the image is not good, redo the scan 

11. once you have a good image, press OK 

12. click the “1:1” button (a couple below the Zoom In/Out buttons on the left side toolbar) 

NOTES: use the ‘hand’ tool (just above Zoom In/Out) to move around on the zoomed image 
use the ‘draw’ tool (has a pencil and is just below the “Start Scan” tool) 
to draw, place cursor where you want the upper-left corner to be, press and hold the left mouse 

button, then drag the cursor to where you want the lower-right corner to be (don’t worry if it 
isn’t exact, you can adjust it later), then release the left mouse button 

13. create each OCR and Mark Detection zone (see section below) 

14. click Apply (to save your edits so far) 

15. setup each Index Field (i.e. one for each column in the .csv) (see section below) 

16. click Apply (to save your edits so far) 

17. map each Index Field to each .csv column (see section below) 

18. click OK (then you will be at the main Capture Pro screen) 
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Mark Detection Zone 

The zone needs to be large enough to handle scan-to-scan variation, but not so large that it another ‘box’ could 

become part of the zone. It is ok for the zone to contain letters; you just need to make sure it doesn’t contain 

more than one ‘box’ in it. A good rule is to make the zone twice as large as the ‘box’. 

You can have a field that contains just one ‘box’ (e.g. ‘Did robot start with a game piece?’), or a field could be a 

group of ‘boxes’ (e.g. ‘Defense ability: low, medium or high’), or a field could be a multiple groups (e.g. ‘Team 

Number’ which is 4 digits; where each digit is its own group). The simplicity, name the field/group so it matches 

the column name in the .csv file. 

When creating a group, you will want to take some care with the zone name so they would show up in a sorted 

list next to each other. A good rule to start each zone with the group’s name; for example, “Defense” group could 

have zone names “Defense - Low”, “Defense - Medium”, and “Defense - High”. Another example would be a field 

that gets the Match number, that would be 3 digits wide, with a group for each digit; and each digit you will have 

multiple ‘boxes’ on the page (i.e. 10 ‘boxes’, 0 through 9). So you could name each zone as “Match Digit 1 - 0”, 

“Match Digit 1 - 1”, … “Match Digit 1 -9”, “Match Digit 2 - 0”, … “Match Digit 2 - 9”, …, “Match Digit 3 - 9”. 

1. get the ‘box’ within view 

2. click the “Create Mark Detection Zone” tool (in lower right, has box with slash coming out of it) 

3. click the ‘draw’ tool 

4. draw the ‘box’ (once you press the mouse a “Mark Detection Zone Setup” dialog will appear 

5. enter the “Zone name:” (e.g. “Had Game Piece” or “Defense - Low”) 

6. set “Filled value:” to what you want to see in the .csv file (e.g. “Yes” or “Low”) 

7. for “Unfilled value:”, only fill it in if the zone is not part of a group. you would enter what you want to see 

in the .csv file if the ‘box’ was not marked (e.g. if the intent is for the ‘box’ to marked if the question’s 

answer is “Yes”, then put in “No”) 

8. for “Side:”, you want “Front” selected 

9. for “Frame:”, you want “Frame” selected 

10. for “Mark sensitivity:”, on the third tick mark (1st one to the left of ‘High’) 

11. if adding to a group: 

a. check “Add zone to group:” 
NOTE: if this is the very first time you checked this box, the “Create New Zone Group” screen 

will appear, skip to step ‘b. iii.’ 
b. if this is the first zone for a group: 

i. click “Add/Edit group:” 

ii. click “New” 

iii. enter the name for the group (e.g. Defense) 

iv. click OK (the “Mark Detection Zone Group” screen should appear) 

v. for “No selection value:”, enter what you want to see in the .csv file when none of the 

‘boxes’ in the group got marked (e.g. digit, use ‘x’; for choices, use ‘none’; for counts use ‘0’) 

vi. click OK (you will now be at the “Mark Detection Zone Setup” screen 

c. for “Group list:”, select the group name this zone belongs to 

12. click OK (you will now be on the “Job Setup” screen) 

13. you may now adjust the box (place cursor over any one of the anchors/black squares, and drag as desired; 

you may find this slightly difficult for overlapping zones, so you may need to move the zone first) 
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OCR Zone 

The zone needs to be large enough to handle scan-to-scan variation, but not so large that any other characters 

would become part of the zone. A good rule is to make the zone so that there is 1/4" between it and any other 

text. The printed text font size needs to be 12 point. 

1. get the ‘box’ within view 

2. click the “Create OCR Zone” tool (in lower right, has box with slash coming out of it) 

3. click the ‘draw’ tool 

4. draw the ‘box’ (once you press the mouse a “OCR Zone Setup” dialog will appear 

5. enter the “Zone name:” (e.g. “Had Game Piece” or “Defense - Low”) 

6. for “Side:”, you want “Front” selected 

7. for “Separation” you want “No separation” and “OCR is located on:” set to “Document level” 

8. click OK (you will now be on the “Job Setup” screen) 

9. you may now adjust the box (place cursor over any one of the anchors/black squares, and drag as desired; 

you may find this slightly difficult for overlapping zones, so you may need to move the zone in order to 

adjust it) 

Index Field 

On the “Job Setup” screen, click the ‘Index’ tab, then click the ‘Document’ tab. 

1. click “Add…” 

2. for “Label:”, enter the name of the field/group (e.g. “Had Game Piece” or “Defense”) 

3. for “Type:”, select “Single Value” 

4. uncheck “Read-only”, “Double Entry”, and “Hidden” 

5. check “Required” and “Check field during scanning” 

6. for “Default value:”, click “Setup…” 

a. scroll to find the ‘Predefined values:’; if the field is an OCR Zone the name will start with “OCR::”, 

if the field is a Marked Detection Zone the name will start with “MD::” 

b. if the field has one ‘box’ or group of ‘boxes’: 

i. select the item (e.g. “MD::Had Game Piece” or “MD::Defense”) 

ii. click “Add Item” 

iii. click “OK” 

c. if the field has multiple groups (e.g. Team number): 

i. select the first group(e.g. “MD::Team Digit 1”) 

ii. click “Add Item” 

iii. select the second group(e.g. “MD::Team Digit 2”) 

iv. click “Add Item” 

v. … 

vi. select the last group(e.g. “MD::Team Digit n”) 

vii. click “Add Item” 

viii. click “OK” 

7. for “Input format:”, enter “?<0>” (but without the double-quotes) 

8. for “Output format:”, enter “[*]” (but without the double-quotes) 

9. click OK (you will back on the “Document” tab) 
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Map Index Fields to .csv Column 

1. on the “Job Setup” screen, click the ‘Output’ tab  

2. select ‘Index:Index To OBDC Database’ (which is under ‘File(1):TIFF’ on the left side) 

3. click “Options...” next to “Document index file:” 

4. map each field 

a. select the ‘Document Information’ item to map (e.g. “DOC_IDX:Team”) 

b. click the down arrow that appears to the far right of that row 

c. select the .csv column name (e.g. “TEAM”) 

d. click OK (you will back on the “Document” tab) 

5. click OK (then you will be on the ‘Job Setup’ screen) 
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Using the System 

Pre-competition 
If there are any OCR zones (e.g. Team Number), then you must pre-print sheets for all combinations of the OCR 

zones. For example, if the Team Number is an OCR zone, then you need to print out sheets for each Team that will 

be at the competition. And for each team, you will need to print as many sheets as there are matches (make sure 

you have enough for any team to reach elimination rounds). So there are 10 teams and they could play 5 matches, 

then you need to print 50 sheets. 

NOTE: if team number is an OCR zone, then to help with sorting in the .csv file, you should always use 4 digits. So 

team number 123, you should put 0123 on the sheet. 

1. print out all the sheets you will need (and some extras) 

2. make sure the .csv file file is ‘emptied’ such that just there is just one line with the column headings (i.e. 

remove data from previous competition) 

3. clean out any previous match image files (i.e. delete everything within the ‘c:\scouting\input’ folder and 

everything within the ‘c:\scouting\output’ folder) 
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Scanning 
NOTE: if this is a the first scan at a competition, be sure you have already followed the steps in the ‘Pre-

competition’ section above 

1. run Capture Pro (Start -> KODAK -> KODAK  Capture Pro Software - > KODAK Capture Pro Software) 

2. on “Batch Manager” screen, click Close 

3. NOTE: ‘scouting’ should be listed in the ‘Page Setup List’ (just under the menubar) 

4. attach the scanner to the PC and power outlet; then open the scanner lid 

5. in the “View” menu, select “Image Viewer Display -> 2 Images” 

6. in the “Batch” menu, select “New…” 

7. for “Job name:”, select “Scouting” 

8. click OK 

9. make sure the scanner’s input tray extender is pulled all the way up 

10. place the scouting sheets (no more than about 20) in the scanner’s input tray 
NOTE: front side goes against the scanner’s tray, and the top edge of the pages goes into the scanner first 

(i.e. flip paper so you see the back of it, then rotate it 180 degrees so the top is now the bottom) 
11. you will want to make sure the paper is scanned straight, so make sure the side guides are against the 

paper 

12. in order to get the best possible data, you want to make sure the pages got scanned correctly. to do that, 

watch each page as it is displayed. look for any non-rectangular images (i.e. those with a lot of black on 

the edges). You can also review image after it is scanner (click on each image in the Thumbnail Viewer at 

the bottom). If you find a bad image, you can re-scan just that one image (details to follow). 

13. click the Start button (green circle with white arrow) 
NOTE: it may take a little bit for the scanner to start scanning (be patient) 

14. If you want to re-scan an image: 

a. click on the image in the ‘Image Viewer’ (so it has a red border around it) 

b. place just that one document in the scanner 

c. in the “Document” menu, select “Rescan Pages” 

d. the image is now be replaced 

15. if you are using OCR fields, if the software has a problem with the OCR, it will display a screen prompting 

you to enter the data (i.e. list of fields appear on the right side, with a yellow triangle next to the field); 

this should only happen if something really bad happened; but if it does, enter the data and press enter 

16. if you want to add more sheets to this batch you can; just place them in the scanner and click ‘Start’ 
NOTE: you do not have to scan all the sheets at once; you can scan some & then come back and do more 

17. when are doing scanning, click “Output Batch” (the checkered flag) 

*** BE SURE TO LOOK for any messages appearing in the lower-right of you screen. If there is an error 

processing the images, a balloon will appear for just a moment. You can also check by selecting “View Batch 

Output Status” from the “Batch” menu. If nothing is shown, the batch was completed. If there are any listed, 

the ‘Status’ column will have some information. If the batch did not finish, then none of the data is saved in 

the .csv file. 

18. you can now open the .csv file (e.g. c:\scouting\aerialassist.csv) and see the new records 
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Viewing Data 
NOTE: this is based on using LibreOffice, which can be found at http://www.libreoffice.org/ 

1. go to the folder with the .csv file (e.g. c:\scouting\aerialassist.csv) 

2. you might want to make a copy of the file and view that (in case you edit the file and accidentally lose all 

the data) 

3. open the .csv (e.g. double-click it) 

4. on the “Text Import” screen: 

a. for “Separator options”, select “Separated by” 

b. for “Separated by”, only “Comma” should be checked 

c. for “Text delimiter”, select “”” 

d. click OK 

5. to quickly sort a single column 

a. added sort filters to the column headings 

i. select the entire first row, which has the column heading names, (click on ‘1’ on the left 

side) 

ii. in the “Data” menu, select “Filter -> AutoFilter” (each column heading should now have a 

down arrow in it) 

b. click the column’s down arrow and pick ‘Sort Ascending’ or ‘Sort Descending’ 

6. to sort on one or more columns: 

a. in the “Data” menu, select “Sort…” 

b. for “Sort key 1”, select the first column you want to sort on; then select its corresponding 

“Ascending” or “Descending” option 

c. if sorting 2 columns, then setup “Sort key 2” 

d. if sorting 3 columns, then setup “Sort key 3” 

e. etc. 

f. for the “Sort key ?” after the last one use just set, set it to “- undefined -“ (e.g. if you setup it up 

to sort on two columns, then “Sort key 3” needs to set to “- undefined -“) 

g. click OK (the ‘Sort’ screen will close and the data will be sorted) 

 


