Debugging FRC Code on the Robot Using Wind River Workbench

A Friendly Guide to the Arcane Process of Debugging FRC Code on the Robot Using Wind River Workbench
(Or: So That’s Why It Didn’t Work!)
So you want to test your robot code, but somehow you just can’t connect to the robot; or you can connect but it throws up some obscure error that you have no idea what on earth it’s talking about; or you can’t even find the SimpleRobot template; or (this especially) you know exactly how the process works, but you forgot ONE LITTLE THING (of course you have no idea what, or where to find it) that’s completely screwed everything up? Fear not, frazzled programmer: for this guide is (unless by a lucky accident you have access to The Jeff®) for you. Read carefully, follow the instructions to the letter, and you will see that it was quite simple* all along! Then you can revel in the glorious feelings of success and relief that result from escaping the dreaded Wind River/FRC Downloading/Debugging Menu and Dialog Labyrinth™.
* Simple, as in with so many hidden pitfalls which are so easy to forget, in places so hard to reach, that it eventually comes to the point where it is almost more simple to do it wrong than right. (And considering how much the process appears to hate being done right, odds are that in the near future FIRST or Wind River will change one trivial factor which will completely invalidate this procedural guide, just to annoy me or you; but the chance of  instructional obsolescence as the result of rapid program evolution is the risk you take with all software how-tos.)
Rule #1:
DON’T PANIC.
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Debugging FRC Code on the Robot Using Wind River Workbench

Step 2. Write code. This is, unfortunately, not something this guide can help you with.
(T'm sorry.) If you do need a useful reference, however, check out
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Step 1. Start a new SimpleRobot Project.
a. Go to File->New->Example…
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ging FRC Code on the Robot Using Wind River Workbench
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b. In the dialog box, highlight

       “VxWorks Downloadable Kernel Module Sample Project”…
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[1. Starting a new SimpleRobot Project]

c. Click Next, then highlight FRC Simple Robot Template (or try other templates if you’re feeling adventurous)…
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d. Then click Finish. You’re done!!*

*Not really. There’s more. A LOT more.
Step 2. Write code. This is, unfortunately, not something this guide can help you with. 

(I’m sorry.) If you do need a useful reference, however, check out C:\WindRiver\docs\extensions\FRC (the WPILib C++ Reference can come in most handy here).

Step 3. Connect to the robot. Now we’re back to stuff this guide can help you with. (I’m 
assuming you’ve finished your first code draft by now and intend to test it.)

a. First, you’ll want to connect to the robot. You can connect directly to the cRIO 

via Ethernet cable (if you don’t know where that would be, consult the relevant mentor), or plug the cable into the router (ditto), and turn the robot on so it and your laptop or computer can communicate.

b. So far so good, right? (Probably because it’s been  all hardware up to now…) 
Now you need to make sure that your laptop/computer’s network connections are correctly set up. (This is one of those steps that can lead to a major “Oh yeah” moment if you forget to do it.) The connection you’re looking for is usually titled “Local Area Connection” (it’s this icon [image: image4.png]chhikersGuideToFRCWindRiver rosoft Word =2 x|
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C\WindRiver\docs\estensions\FRC (the WEILib C-++ Reference can come in
most handy here),

Step_3. Now back to stuff this guide can help you with. (I'm assuming you've finished
Yous first code draft by now and intend fo test it

a First, you'll want to connect to the robot. You can connect directly to the cRIO.
via Ethernet cable (if you don’t know where that would be, consult the
relevant mentor), or plug the cable into the router (ditto), and tura the robot on
so it and your laptop or computer can communicate.

b, So far so good, right? (Probably because if's been all hardware up to now...)
Now you need to make sure that your laptop/computer's network connections
are comectly set up. (This is one of those steps that can lead to a major “Oh
yeah” moment if you forget fo do it The connection you're looking for s
usually titled “Local Area Connection”

¢ You have two options now: deploy the code directly (if you're confident that
your code works), overwriting previous cods on the robot, or debug the code,
taking advantage of numerous debugging tools, but losing the code when the
debug session ends. If you choose the second route (highly advisable if you're
starting from scratch), continue to Step 4. Otherwise, read on.

¢. Deploying is simple: make sure
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, with or without X; or Show all Connections, then double-click the Local Area Connection…)
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[3. Connecting to the robot]
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Now you’ll be looking at this window (below left); select Internet Protocol (TCP/IP) and click Properties; then you’ll get the window below right. Select the “Use the following IP address” radio button and set IP address to 10.xx.yy.6 (or dot−anything except 1 [that’s the router] or 2 [that’s the robot] or 5 [that’s the camera]) where xxyy is your team number; to give a completely random example, team 1511 would set IP address to 10.15.11.6. Subnet mask should be set to 255.0.0.0 {CHECK THIS}. Then you can click OK and OK and whatever else you need to get rid of all those pesky windows, because you’re done configuring your network to talk to the robot![image: image30.png]& Device Debug - thunderbot201¢
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FIX ME~!!!
d. Did I say done? Whoops, one more thing! (I almost forgot to include this myself—see how insidiously this process conspires to make you do it wrong?) One final network configuration task to remember is to disable any wireless networks, because if they’re left on they can seriously confuse VxWorks when it tries to connect (the stupid thing). Right click the icon [image: image6.png]chhikersGuide ToFRCWindRiver rosoft Word =18 x|
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Tompletely random example, team 1511 Would set LE address to 1U.15.11.6.
Subnet mask should be set to 255.255.255.0. Then you can click OK and OK
and whatever else you need to get rid of all those pesky windows, becanse
you're done configuring your network to talk to the robot.
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4. Did say done? Sorry, I almost forgot to include this myselfl One final
network configuration task to remember is to disable any wireless networks,
becase if they're left on they can seriously confuse VxWorks when it ries to
connect (the stupid thing). Right click the icon

e At this point, you have two options: deploy the code directly (if you're
confident that your code works), overwriting previous code on the robo; or
debug the code, taking advantage of numerous debugging tools, but losing the
code when the debug session ends. If you choose the second route (highly
advisable if you're starting from scratch), continue to Step 4. Otherwise, read
on
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, or the name of the wireless connection in the Network Connections window (aren’t you sorry you closed it now?), and select Disable. Now you’re done (with network configuration, at least). 
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Step 4. Deploy code. At this point, you have two options: you can deploy the code 
directly (if you’re super-confident that your code works), overwriting previous code on the robot; or you can choose to debug the code, taking advantage of numerous debugging tools, but losing the code when the debug session ends. If you choose the second route (highly advisable if you’re starting from scratch), skip to Step 5. Otherwise, read on.
a. Deploying is simple (but remember the note on the title page): make sure the 

robot is on, your connection is secure, and your program has compiled (via right-click->Build Project, or Ctrl-Shift-A)…
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… without any errors whatsoever. Now you’re ready—NOT!!

b. You’re only ready if you’ve already set the downloader preferences. If you 

haven’t, go to Window->Preferences…
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…then click on FIRST Downloader Preferences in the sidebar.

[4. Deploying Code]
c.    Now set your team address (easy enough)—and the file path to the file you 
want to download, which is hideously complex; the path is (pay close attention):

[WorkDir]\[NOP]\PPC603gnu\[NOP]\Debug\[NOP].out 

(where [WDir] is the path to Wind River’s workspace—it asks you about it on startup until you get annoyed with it and stop it from asking; the default is C:\WindRiver\workspace—and [NOP] is the name of your project, SimpleTemplate if you didn’t change it; did I mention that you can change the name by right-clicking the project name in the Project Explorer [top left pane] and selecting Rename? I didn’t? Well, now I did …).
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d.   Now click Apply, then OK, and you’re all set to Deploy. Seriously! That’s it. 

All you have to do now (after triple-checking your connection) is select FIRST->Deploy, and then wait. A long time. While you’re waiting, I’ll just take a moment to tell you that Undeploy will erase your code from the robot again if for any reason you want to start over with a clean slate.

[image: image10.png]=181]

A N

52 SimpeTemplete (Wind River VxWorks 6.3
3 thunderbot2010 (Wind River WxWorks 6.
25 thunderbot2011 (Wind River WxiWorks 6.

K1l |

B Remote systems 33 =0
2|pa|glal w|
BS

I
2 Local Fes
Tk Local shells

£1-@ wind Rver Rogires

RobotDemo (void) :
stickL(1),
stickR(2),
tracker (CHANNEL LEFT, CHANNEL_CENTER, CHANNEL_ RIGHT)

// as they are declared sbove.

frontleft = new CiNJaguar (7):
frontRight = new CANJaguar (S);
backLeft = new CiNJaguar (6):
backRight = new CANJaguar (4} ;

)

e
* Tries to follow line with tracking sensors.
"

void Autonomous (void]

¢

7"
7"
7"
7"
7"
7"
//Congruent to nonsense by AABEA

The uye, the uye, vhat a vonderous wye!

It loops and it twirls,
Though it be evil
That monsterous weevil

by and by

We adnire the wonderful wye

(il | EE | v -5 -G o [ oevievebug
[ projcterp 57 2 Debugsym | = O [0 Trackerh | ) Trackercop % ebug 3 =0
BE|le@-~ -

@ defaul (focahost) 2 Tasks [ & Terminal |2 Problems | = Properties | BB guid Console 52 ] Console | =g

18 vworksex_10.15.11,2 (Wind River g-e6 e o%(268 .~

=]

kil I _>l_I
| = Wikable St Isert | 3141 [T sotaon] @ |

Bstart| [ Device bebug sl





e. If you’ve done everything right, you’ll get no error messages and the code 

will be on the robot. Before you can test the code, however, you must first reboot the robot via a power-cycle, but then you’re finally READY TO RUN YOUR CODE!!!!! (You’ll have to test it yourself. I can’t help you there.)
[4. Deploying Code]
f. Potential errors (no screenshots because they’re no fun to see):

· “Backend not connected”: your connection came apart somehow. Check to make sure you really did do every step right (including turning on the robot!)

· Most other complex error messages: usually come from a version mismatch between the computer’s FRC C++ base and the cRIO software image. In this case, consult the Jeff® or another programming mentor and ask if you should update the image (using the FRC cRIO Imaging Tool) or not, or whether it’s yet another, even more hideously complex problem; if the latter two cases, just updating the image can lead to even more problems, which is why mentor feedback is imperative.

Step 5. Debug code. This step is probably the most fun* of all, because (a) it has the 

most component parts and deviously hidden parameters and (b) it requires that all previous steps have been completed 100% error-free, providing myriad possibilities of error-compounding. And on that happy note, let’s begin!
*“Fun” in the sense of “simple”.

a.   First of all, we need a VxWorks connection. No, wait: first of all you have to 

make sure that there is no code deployed on the robot. Otherwise, your Debug session will not work, and in some cases you may not even be able to start a VxWorks connection. To do this, make sure your connection to the robot is secure (Ethernet cable is connected, robot is on, etc.), then go to FIRST->Undeploy (see Step 4.d). This will wipe all deployed code off the robot and allow you to use the Debug session.

b.   Now you can start up the VxWorks connection. If you already have one set up 

from previous debugging exploits, you can skip to substep 5.f with delirious joy, because you don’t have to do this burdensome task anymore. If not, however… We start with Target->New Connection.

[image: image11.png]® De

e Debug - thunderbot 2014

Fle Edt Refactor Nevigate Search Project Anslyze Run | Target FIRST Window Help

| 8609 - | | i 5 NewRemoteRagsty
[g-3-we-— - Pess sy
[P Project Explor. 23 2 Debug Symbol| = || [8 AutoMap W LaUnch Default Reastry
e (SR
ERA-CN o 1pae 01 Cornee:
o2 pae S Dsmmect
] B‘unu:' :ygets (PPCED3gnu - debug) 22 ::g P
) Ichudes o Show Target Server Log
Gy canjaguar o Rese: connested Targe:
& recensn 97 =i Host Shiell
[} AukoFunctonsh 02 331710 11:08 ) o
1) AutoMap.h 313 5/22/10 12:12 AM he. as//

[ Controls.n30 4/11/10 4:36 PH bear
(1) DashboardDatasender.h 172 2/16/10
(1) DSMap.h 268 3(5{109:54 PH heydor
1) EncoderPID.h 205 2/20/10 422 At
[} Hanger 1 270 3/5/10 9:58 PH heydow
53 mageprocessing.h

1) 10Map. 344 10/3010 10:45 AM bee

100/ // % Dol
101Hde @
102Hde g 0y
soomae 20

1044de
neag B Torget ode

ST

ST
0.0¢  // pover lev
0.0f  // distance
1 // code for the
E false // are ve us
AL o /4 angle to

D

=181]

@ | vi 75 B Remote yste.. [ Dovice obug G ArplcatonD.
= 5)[% reatponts 23 ooeug] =01

e Bl o 7/ ang1e

N 6.0t // aista

1Econ o 7/ angle

T oor o 77 disca

] L06k#define AUTO_BLOCK DIST 3a.0f // atscance
Kicker.h 344 10/30/10 10:48 AM bear 107#define AUTO_BLOCK_ANGLE GOAL O // angle to =
= _BLOCK_ANGLE_( -y 52 WitR 40 Om &5 = O
. mNewHanntham 4/14/mun5n_rg,—| i08#define AUTO_BLOCK DIST_GOAL O /7 distance LILLILS
1094endif -
2 Remote systems 5 =0 110 r wa|
< K | > —
= | 9 e & &
2w %) o Brote [P 1o [ e (D e (D corl Bows 5o =0 Sl B %k
g-alE =] & 268 7
ElE] E =
-
1 vworksex_10.11.15.2 (Wind River ixworks
18 vaworksex_10.15.11.2 (wind River ixworks
[l ————— | _>l_I I} _>l_I
|00 thunderbotz01o wind River vxWorks 6.3 Dowloadsble Kernel Modle rofct) [ smdean (@]

@istart| @ (2§ [© Device Debug- thund... ] DeployingandDebugaing... | B HechhikersGuideToFRC. . |





c. The first screen is simple (in its usual sense, astonishingly)—select “Wind River VxWorks 6.x Target Server Connection” and click Next.
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[5. Debugging Code]
d. The next screen is (of course) more complicated. Here you need to set two 

things: the target IP address (10.xx.yy.2 where xxyy is team address), and the kernel image (select the radio button File to enter the file path). This last is C:\WindRiver\WPILib\vxWorks (if you can’t find it, you’re in serious trouble). The relevant portions of the dialog are shown below.
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e. Now you can click Next, Next, Next, Next, and Finish! The defaults given in the following screens should serve you well. Note the checkbox “Immediately connect to target if possible” on the final screen—this can be nice to have enabled (but is not mandatory).

f. If you leave the box unchecked or want to reconnect a dormant connection, right-click the connection name in the Remote Systems pane (lower left) and select “Connect [connection name]”, or highlight the name and click the circled icon. Once you wait long enough for the connection to go through (and you are physically connected to the robot or its router, and they’re both turned on), you have your VxWorks connection to the robot! Hooray!
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[5. Debugging Code]
g. Now that you have your connection, the real fun begins: setting up the Debug process. First of all, set your FIRST Downloader Preferences if they haven’t already (see Step 4.b/c). Then make sure that you are in Device Debug perspective (circled). Now go to Run->Open Debug Dialog… to set Debug preferences (unless, again, you have already done so, in which case you can skip merrily to step 5.m!)
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One more note since I have space here: the Debug Dialog can also be by clicking the little triangle next to the bug on the toolbar:
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[5. Debugging Code]
h. In the Debug dialog, you may just see this screen:
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In this case, select Kernel Task and click the New Button (circled). Then (or if you already have the Debug partially set up) you’ll get to see the real screen, which will look something like this:
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[5. Debugging Code]
i. Now you can start setting parameters—in the Main tab, the connection to use (select the one you’ve already set up) and the Entry Point (notes on this below):
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(When first setting the parameters, you’ll have to browse for the Entry Point. This can be hard to find, so here are some directions: In the dialog, expand the name of your project—ThunderBot2010 in the example—then in the search box above, type in “FRC”; this will remove most of the huge number of extra symbols and allow you to choose the correct one, which is: 

FRC_UserProgram_StartupLibraryInit

Then you can return to the rest of the parameters, described below.)


[5. Debugging Code]
j. More parameters—in the Download tab, the File should be the same insanely long file path (minus the workspace directory prefix) as was used in Step 4.c (if there isn’t one, use the Add… button).
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k.   Yet further parameters—in the Projects To Build tab, it’s nice to have the 

project being worked on included (so it gets built automatically before download to the robot) or removed (so you have a few less seconds to wait); the Add Project… and Remove buttons, respectively, can help here. In the Debug Options tab, the “Break on Entry” checkbox can be useful (giving you another checkpoint before allowing the robot to move), and the “Automatically attach spawned Kernel Tasks” box must be checked, or else your Debug will fail pathetically.
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[5. Debugging Code]
l.   Even more parameters—and the fun thing about these is that you have to have 

your VxWorks connection up and running or it won’t even allow you to edit them! Return to the Download tab, highlight your project, and select Edit…

This calls up a further dialog, where you should check “Download even if not modified” (which can be useful if you want to test the same code multiple times without changing anything), then click Advanced Options….
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This opens up a yet further dialog box. Here, “do not unload the existing module” should be unchecked (so the existing module will be unloaded—i.e. you will overwrite your previous code on the robot). [Side note: apparently the default is to unload the module, but for some reason the box is often checked and has to be unchecked. How this can be is one of the unfathomable mysteries of WindRiver.]
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[5. Debugging Code]
m.    Now that you’ve tracked down and set all the necessary parameters, and your 
VxWorks connection is up and running, and you’re connected to the robot with correctly set-up networks, and you’ve written your code starting from the base Simple Template, you’re finally ready to Debug! If you’re in the Debug dialog, just click Debug; if not, click the bug icon on the toolbar (shown above at step 5.g). Now you can wait…and wait…and wait…for the code to build, download, and start.
n. Once you get done waiting, and assuming you have neither errors due to not 

correctly following these instructions nor ones due to more arcane reasons, you might have to Continue the program past breakpoints (the one on entry, plus any others you might have added yourself) using the red-circled icon (a green arrow when enabled). The green-circled icons on right and left terminate a Debug process and remove a terminated process, respectively, when you’re done with them. 


o.     If you want to print out debugging information and get to see it printed, a 

useful tool can be the Target Console. Right-click your VxWorks connection and select Target Tools->Target Console. Now you’re completely, 100% ready to debug—all you need to do now is find the hidden errors in your code*…. But rejoice! For you have escaped the Wind River/FRC Downloading/Debugging Menu and Dialog Labyrinth™!!!
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* A task that, though difficult and with many pitfalls, is so much easier than getting the Debug process started in the first place that I don’t really need to help you with it.

[5. Debugging Code]
p.    …unless, of course, you got errors. “Backend not connected” and version 

mismatch problems were discussed in Step 4.f; other possibilities include:

· “Timeout on server” can often signify that you have a program deployed on the robot, which makes the VxWorks connection fail. In this case, your solution is FIRST->Undeploy.
Appendix
And now… in the spirit of FLR 2009… A Poem. (Or several.)

Found miraculously in the code of MyRobot.cpp when the author foolishly left control of the laptop in the mischievous hands of his younger brother Manuel (but some, sad to say, written with equal foolishness by the author himself). Feel free to disregard this appendix completely; in fact, I’d advise it, as you proceed to the poems at your own risk. (Minor edits—removing // comment marks, adding titles, etc. were performed by the author, but these make the reading experience no less traumatic.)
(Limerick) Ode on the Wye (the branched tracking line in the 2011 Game)
The wye, the wye, what a wonderous wye!

It loops and it twirls, by and by

Though it be evil

That monsterous weevil

We admire the wonderful wye

Congruent to nonsense by AABBA

Haiku on Circle-squaring
Squaring the circle

Is much fun for great Peters

Who like to give up

Haiku on Robot Names



The Thunder Mammoth,

the baby Lightning mammoth

Splendriferous names

Haiku on Poems and Penguins
Poems in code are fun

Penguins in code are better

Huge Penguins are best

Autobiographical Haiku



I create haikus

Waiting for Peter to come

So tracking code works


[Appendix]

Waiting



Every hour I fall asleep

Every day I write some more

Waiting for robots to beep

Is such a boring chore

Penguins
Penguins, we adore thee

Admire and uphold thee

And then we want to feed thee

Buckets of krill

Sensible Haiku (originated by Andy Melnick, then transcribed by my brother, with 

a decisive but awesome misspelling) 
Haikus are simple

But not all of them make sense

Refrigetator

Meta-Haiku (by the author)
The first line is five

The second line is seven

The last line is five

Penguin Robot Names Haiku



Big Penguin is fat

That Little Penguin is cute

Both are robot names

Syzygymonstrum
Syzygymonstrum

Integer monster of night

Voracious demon

A thoroughly inexplicable commentary on the inexpressibly

  awesome game of Minecraft



When I write haikus

I hear quiet moos

Minecraft playing people

Falling off a steeple

And losing every heart

They are not that smart

[Appendix]

Cookies [first line written by the author, last two added by his brother;


N.B. I disagree with his conclusion]
I!! HAVE!! COOOKIIEES!!!!!

We writes some awful haikus

Cookie breath stinks

Rule #3: If anything goes wrong, it’s 


all my fault.








      Rule #2: If in doubt, call The Jeff®.
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