2018:Programming: Difference between revisions
From 1511Wookiee
Jump to navigationJump to search
Programming (talk | contribs) No edit summary |
Programming (talk | contribs) No edit summary |
||
Line 1: | Line 1: | ||
<div class="mw-parser-output"> | <div class="mw-parser-output"> | ||
= Outstanding Tasks - Scouting App = | = Outstanding Tasks - Scouting App = | ||
In no particular order! | In no particular order! | ||
*Update tables classes to define new db schema for 2018 (thunderscout.db package, class ResultsTable) | *Jeff | ||
*Update EventStorage class to create new tables (EventDbHelper internal class) | **Update tables classes to define new db schema for 2018 (thunderscout.db package, class ResultsTable) | ||
*Update EventStorage class to read/write new tables (methods getAllSavedMatches() and saveMatchData()) | **Update EventStorage class to create new tables (EventDbHelper internal class) | ||
* | **Update EventStorage class to read/write new tables (methods getAllSavedMatches() and saveMatchData()) | ||
*Update webserver output to match new match data (Webserver class) | **Update webserver output to match new match data (Webserver class) | ||
**New bluetooth sync | |||
& | *Alex | ||
**Feedback from Carol - for scored in switch & scale do the following: | |||
<div class="mw-parser-output"><div class="mw-parser-output"><div class="mw-parser-output"> | ***Rename DNA to be the verbose version: "Did not attempt" | ||
<div class="mw-parser-output"> | ***To give more horizontal space and separate things better, move alliance/opponent selections to next line, consider centering them left/right | ||
***Disable Alliance/Opponent when they don't make sense (you do this by listening to button selections in the Java code for the fragment - see last year commented out code for an example) | |||
***Default to "Did not attempt" | |||
***Also default to "Alliance" selected | |||
**In the data class (ScoutingMatchData) enums for Score, remove "NOT_CHECKED" option; this is not relevant anymore with defaulting "Did not attempt" to on. The constructor should default score/switch values to "did not attempt" to match the UI. | |||
**Similar for Scoring on Exchange: | |||
***DNA should be "Did not attempt" and selected by default | |||
***Remove "not checked" from data class and default to "did not attempt" | |||
**For climbing: | |||
***Make "Not on platform" selected by default | |||
***Remove "not checked" from data class, default to "did not attempt" | |||
***Rename the "failed" checkbox to "Climb attempted, but unsuccessful" | |||
<div class="mw-parser-output"><div class="mw-parser-output"><div class="mw-parser-output"><div class="mw-parser-output"> | |||
Controls: Kyle & Adrian & Cameron | Controls: Kyle & Adrian & Cameron | ||
Line 46: | Line 35: | ||
Auto: Josh & Kate | Auto: Josh & Kate | ||
Lights: Zack E</div> </div> </div> </div> | |||
Lights: Zack E </div> </div> </div> | |||
</div> | |||
== Autonomous == | == Autonomous == | ||
Line 80: | Line 66: | ||
*[[2009:Programming]] | *[[2009:Programming]] | ||
</div> | </div> </div> | ||
</div> | </div> |
Revision as of 19:32, 9 February 2018
Outstanding Tasks - Scouting App
In no particular order!
- Jeff
- Update tables classes to define new db schema for 2018 (thunderscout.db package, class ResultsTable)
- Update EventStorage class to create new tables (EventDbHelper internal class)
- Update EventStorage class to read/write new tables (methods getAllSavedMatches() and saveMatchData())
- Update webserver output to match new match data (Webserver class)
- New bluetooth sync
- Alex
- Feedback from Carol - for scored in switch & scale do the following:
- Rename DNA to be the verbose version: "Did not attempt"
- To give more horizontal space and separate things better, move alliance/opponent selections to next line, consider centering them left/right
- Disable Alliance/Opponent when they don't make sense (you do this by listening to button selections in the Java code for the fragment - see last year commented out code for an example)
- Default to "Did not attempt"
- Also default to "Alliance" selected
- In the data class (ScoutingMatchData) enums for Score, remove "NOT_CHECKED" option; this is not relevant anymore with defaulting "Did not attempt" to on. The constructor should default score/switch values to "did not attempt" to match the UI.
- Similar for Scoring on Exchange:
- DNA should be "Did not attempt" and selected by default
- Remove "not checked" from data class and default to "did not attempt"
- For climbing:
- Make "Not on platform" selected by default
- Remove "not checked" from data class, default to "did not attempt"
- Rename the "failed" checkbox to "Climb attempted, but unsuccessful"
- Feedback from Carol - for scored in switch & scale do the following:
Controls: Kyle & Adrian & Cameron
DriveMeyer: Josh
Arm/Intake: Kate & Ethan
Ramp: Kate & Josh
Auto: Josh & Kate
Lights: Zack EAutonomous
Do nothing
Cross auto line
Sense switch and place cube in switch and cross auto lineProgramming Sub-pages and Links
- Documentation
- SVN
- 2018:Robot_IO_Map