2018:Programming: Difference between revisions

From 1511Wookiee
Jump to navigationJump to search
No edit summary
No edit summary
Line 1: Line 1:
<div class="mw-parser-output"><div class="mw-parser-output">General programming stuff relevant to all subsystems should be documented here. <div class="mw-parser-output"><div class="mw-parser-output">
<div class="mw-parser-output">
<div class="mw-parser-output">
<div class="mw-parser-output">
<div class="mw-parser-output">
<div class="mw-parser-output">
== Outstanding Tasks - Robot Code ==
Split up by subsystem - responsible veteran student in (), student(s) doing actual code, if different, in []. '''These are not in any particular order!'''
*Review questions for mechanism teams and get answers (Kate, Ethan)
*Document on Wiki (or link to gdocs) autonomous modes. Include Names/Number assignments for Dashboard/Controls to use (Kate, Josh)
*<s>Controls: '''document '''which specific model of gamepads we will use this year on the controls wiki (Kyle)</s>
*<s>Controls: Get details on to IO map wiki page for both game pad operations&nbsp; (Kyle)</s>
*Controls: Implement controls code on robot (Kyle)
*<s>Drive: Test/Evaluate new gyro (SPI-based interface instead of analoggyro - already installed on test board) (Josh)</s>
*Drive: Examine auto modes and decide what range(s) of auto driving actions need to work the best, then make them happen (Josh)
*<s>Auto/Vision: Where on robot do(es) camera(s) need to go? Document on Robot Design page on Wiki and talk to relevant design teams so they carve out that place!&nbsp; (Kate)</s>
*Old robots: Bring 2015, 2016, 2017 all up to 2018 image and ported code. Test. (anyone, but this is super low priority)
&nbsp;
<div class="mw-parser-output">&nbsp;</div> </div></div></div></div>
= Outstanding Tasks - Scouting App =
= Outstanding Tasks - Scouting App =


In no particular order!
In no particular order!


*Update tables classes to define new db schema for 2018 (thunderscout.db package, class ResultsTable)  
*Jeff
*Update EventStorage class to create new tables (EventDbHelper internal class)  
**Update tables classes to define new db schema for 2018 (thunderscout.db package, class ResultsTable)  
*Update EventStorage class to read/write new tables&nbsp; (methods getAllSavedMatches() and saveMatchData())  
**Update EventStorage class to create new tables (EventDbHelper internal class)  
*Continue work on UI screens (layout XML mostly)
**Update EventStorage class to read/write new tables&nbsp; (methods getAllSavedMatches() and saveMatchData())  
*Update webserver output to match new match data (Webserver class)  
**Update webserver output to match new match data (Webserver class)  
 
**New bluetooth sync 
&nbsp;
*Alex
</div> </div> </div>
**Feedback from Carol - for scored in switch & scale do the following:
<div class="mw-parser-output"><div class="mw-parser-output"><div class="mw-parser-output">
***Rename DNA to be the verbose version: "Did not attempt"
<div class="mw-parser-output">
***To give more horizontal space and separate things better, move alliance/opponent selections to next line, consider centering them left/right
== Programmers: ==
***Disable Alliance/Opponent when they don't make sense (you do this by listening to button selections in the Java code for the fragment - see last year commented out code for an example)
 
***Default to "Did not attempt"
***Also default to "Alliance" selected 
**In the data class (ScoutingMatchData) enums for Score, remove "NOT_CHECKED" option;&nbsp; this is not relevant anymore with defaulting "Did not attempt" to on. The constructor should default score/switch values to "did not attempt" to match the UI.
**Similar for Scoring on Exchange:
***DNA should be "Did not attempt" and selected by default
***Remove "not checked" from data class and default to "did not attempt" 
**For climbing:
***Make "Not on platform" selected by default
***Remove "not checked" from data class, default to "did not attempt"
***Rename the "failed" checkbox to "Climb attempted, but unsuccessful"   
<div class="mw-parser-output"><div class="mw-parser-output"><div class="mw-parser-output"><div class="mw-parser-output">
Controls: Kyle & Adrian & Cameron
Controls: Kyle & Adrian & Cameron


Line 46: Line 35:


Auto: Josh & Kate
Auto: Josh & Kate
 
Lights: Zack E</div> </div> </div> </div>  
Lights: Zack E </div> </div> </div>
</div>
 
== Autonomous ==
== Autonomous ==


Line 80: Line 66:
*[[2009:Programming]]  
*[[2009:Programming]]  


</div>
</div> </div>
</div>
</div>

Revision as of 19:32, 9 February 2018

Outstanding Tasks - Scouting App

In no particular order!

  • Jeff
    • Update tables classes to define new db schema for 2018 (thunderscout.db package, class ResultsTable)
    • Update EventStorage class to create new tables (EventDbHelper internal class)
    • Update EventStorage class to read/write new tables  (methods getAllSavedMatches() and saveMatchData())
    • Update webserver output to match new match data (Webserver class)
    • New bluetooth sync
  • Alex
    • Feedback from Carol - for scored in switch & scale do the following:
      • Rename DNA to be the verbose version: "Did not attempt"
      • To give more horizontal space and separate things better, move alliance/opponent selections to next line, consider centering them left/right
      • Disable Alliance/Opponent when they don't make sense (you do this by listening to button selections in the Java code for the fragment - see last year commented out code for an example)
      • Default to "Did not attempt"
      • Also default to "Alliance" selected
    • In the data class (ScoutingMatchData) enums for Score, remove "NOT_CHECKED" option;  this is not relevant anymore with defaulting "Did not attempt" to on. The constructor should default score/switch values to "did not attempt" to match the UI.
    • Similar for Scoring on Exchange:
      • DNA should be "Did not attempt" and selected by default
      • Remove "not checked" from data class and default to "did not attempt"
    • For climbing:
      • Make "Not on platform" selected by default
      • Remove "not checked" from data class, default to "did not attempt"
      • Rename the "failed" checkbox to "Climb attempted, but unsuccessful"

Controls: Kyle & Adrian & Cameron

DriveMeyer: Josh

Arm/Intake: Kate & Ethan

Ramp: Kate & Josh

Auto: Josh & Kate

Lights: Zack E

Autonomous

Do nothing

Cross auto line

Sense switch and place cube in switch and cross auto line

Programming Sub-pages and Links

Programming Archives